fbpx

Since Booster for WooCommerce plugin v3.0.0, free plugin version is no longer required to run the Plus version. Booster Plus updates can be done automatically from your Plugins page – same as with free plugins from wordpress.org (however you will need to enter your site key).

If you have Booster Plus below v3.0.0 installed, please follow these steps:

  1. Download new version’s zip file from your account page.
  2. Deactivate and delete old Booster Plus version (don’t worry your saved settings won’t disappear).
  3. Install new version’s zip.

If you have Booster Plus below v3.0.0, you can still use it with free plugin v3.2.4 or below (you can download any previous version from https://wordpress.org/plugins/woocommerce-jetpack/advanced/).

For more information please visit Frequently Asked Questions page, or Contact Us page.